Film-Tech Cinema Systems
Film-Tech Forum


Post New Topic  Post A Reply
my profile | my password | register | search | faq & rules | forum home
  next oldest topic   next newest topic
» Film-Tech Forum   » Operations   » Film Handlers' Forum   » Belt For Prevost P-93???

   
Author Topic: Belt For Prevost P-93???
Mark Gulbrandsen
Resident Trollmaster

Posts: 16157
From: Bountiful, Utah
Registered: Jun 99


 - posted 07-20-2004 11:44 AM      Profile for Mark Gulbrandsen   Email Mark Gulbrandsen   Send New Private Message       Edit/Delete Post 
Does anyone know the metric belt number thats used in this projector? There are none in the U.S. available from either Prevost parts source that we've been able to find at the moment. Any other dealers have one or two in stock please call us.
Mark @ CLACO

CLACO Equipment And Service
1212 South State St
Salt Lake City, UT
84111
801-355-1250

[ 07-20-2004, 01:17 PM: Message edited by: Mark Gulbrandsen ]

 |  IP: Logged

Ferdinando Innocenti
Film Handler

Posts: 79
From: Genova / Italy
Registered: Jun 2004


 - posted 07-20-2004 04:25 PM      Profile for Ferdinando Innocenti   Email Ferdinando Innocenti   Send New Private Message       Edit/Delete Post 
I changed two just today. But I will be able to measure them only on tuesday. If no one can help you, I will post them the day after tomorrow.

Ciao
Nando

 |  IP: Logged

Mark Gulbrandsen
Resident Trollmaster

Posts: 16157
From: Bountiful, Utah
Registered: Jun 99


 - posted 07-21-2004 10:49 PM      Profile for Mark Gulbrandsen   Email Mark Gulbrandsen   Send New Private Message       Edit/Delete Post 
Thanks for the offer but I have to thank a U.S. reverse scan manufacturer who opened up his P-93 and gave us the belt measurements and there are three belts on thew way to the theatre. Its a metric polyurethane belt. I also have to laugh at tone U.S. supplier that wanted 110.00 per belt [Eek!] ! The belts were under 30 dollars U.S. each from our local bearing supplier [thumbsup] .
The belts I need to replace in this pair of P-93's are only 15 years old!
Mark @ CLACO
(Live from Elko, NV.)

 |  IP: Logged

Gordon McLeod
Film God

Posts: 9451
From: Toronto Ontario Canada
Registered: Jun 99


 - posted 07-22-2004 10:53 AM      Profile for Gordon McLeod   Email Gordon McLeod   Send New Private Message       Edit/Delete Post 
So to enlighten the rest of us what is the spec on the belt

 |  IP: Logged

Juan Urias
Film Handler

Posts: 22
From: Chicago, IL
Registered: Oct 2003


 - posted 07-22-2004 04:09 PM      Profile for Juan Urias   Email Juan Urias   Send New Private Message       Edit/Delete Post 
hey mark i don't want to be nosey but call me.i have a question on this belt...........Juan

 |  IP: Logged

Mark Gulbrandsen
Resident Trollmaster

Posts: 16157
From: Bountiful, Utah
Registered: Jun 99


 - posted 07-22-2004 05:23 PM      Profile for Mark Gulbrandsen   Email Mark Gulbrandsen   Send New Private Message       Edit/Delete Post 
I will post the pertinent belt specs later tommrrow after I install them. The only really special part about the belt is that its polyurethane so it can run in an oil environment as in the P-93. I believe these are the only P-93's that CLACO ever sold, but there may be two more pair in an area that I don't normally service. These are 15 years old now and have given their owner zero trouble which is pretty amazing.

Mark @ CLACO
(Live from Winnemucca, NV.)

 |  IP: Logged

Trevor Bailey
Expert Film Handler

Posts: 113
From: Woonsocket, RI
Registered: Jun 99


 - posted 07-23-2004 03:27 PM      Profile for Trevor Bailey   Author's Homepage   Email Trevor Bailey   Send New Private Message       Edit/Delete Post 
It may be important to note for others out there, that your particular P-93 may not have the original metric belt. Some were converted to a single phase motor using a different pulley and belt (I believe this was a Xetron mod).

 |  IP: Logged

Mark Gulbrandsen
Resident Trollmaster

Posts: 16157
From: Bountiful, Utah
Registered: Jun 99


 - posted 07-23-2004 05:28 PM      Profile for Mark Gulbrandsen   Email Mark Gulbrandsen   Send New Private Message       Edit/Delete Post 
These P-93 Prevosts are indeed Xetron modified Prevosts with a SINGLE PHASE 1800 RPM motor. The Belt used in this machine is a T10-660(metric) Polyurethane timming belt. CLUE! These belts DO NOT cost 120.00 as Big Sky and Newmade might want you to believe.

Interestingly there is zero wear on the gear trains in these machines after 15 years of daily use.... The booths here in the Park Cinemas are clean enough to eat off the floor!! They are indeed doing film right at this location.

The funny thing is that the belts are probably made here, shipped to Italy and then shipped back here to be distributed all over again.....

Mark @ CLACO
(Still alive in Winnemucca, NV.)

 |  IP: Logged

Gordon McLeod
Film God

Posts: 9451
From: Toronto Ontario Canada
Registered: Jun 99


 - posted 07-23-2004 05:43 PM      Profile for Gordon McLeod   Email Gordon McLeod   Send New Private Message       Edit/Delete Post 
Originally when Cineplex (now Cineplex Odeon) converted from 16mm to 35mm most of the 35mm was Prevost P55 and those machines just ran and ran and ran till each location closed
Sometimes you see one of them on Ebay
The prevost P70 (favorite70) is a very durable and excellent 70mm machine and the favorite16b is an excellent and rugged 16mm machine
The prevost lamphouses though I always found dificult to align and get a good light out of

 |  IP: Logged

Daryl C. W. O'Shea
Film God

Posts: 3977
From: Midland Ontario Canada (where Panavision & IMAX lenses come from)
Registered: Jun 2002


 - posted 07-23-2004 06:56 PM      Profile for Daryl C. W. O'Shea   Author's Homepage   Email Daryl C. W. O'Shea   Send New Private Message       Edit/Delete Post 
quote: Gordon McLeod
Originally when Cineplex (now Cineplex Odeon)
...now Cineplex Galaxy. [Smile]

 |  IP: Logged

Ferdinando Innocenti
Film Handler

Posts: 79
From: Genova / Italy
Registered: Jun 2004


 - posted 07-25-2004 05:08 PM      Profile for Ferdinando Innocenti   Email Ferdinando Innocenti   Send New Private Message       Edit/Delete Post 
My P-93 have the same belts (T10-660): they run from 1997, backwards and forwards; I often open the projector head, and they are really perfect!

Ciao
Nando

 |  IP: Logged



All times are Central (GMT -6:00)  
Post New Topic  Post A Reply Close Topic    Move Topic    Delete Topic    next oldest topic   next newest topic
 - Printer-friendly view of this topic
Hop To:



Powered by Infopop Corporation
UBB.classicTM 6.3.1.2

The Film-Tech Forums are designed for various members related to the cinema industry to express their opinions, viewpoints and testimonials on various products, services and events based upon speculation, personal knowledge and factual information through use, therefore all views represented here allow no liability upon the publishers of this web site and the owners of said views assume no liability for any ill will resulting from these postings. The posts made here are for educational as well as entertainment purposes and as such anyone viewing this portion of the website must accept these views as statements of the author of that opinion and agrees to release the authors from any and all liability.

© 1999-2018 Film-Tech Cinema Systems, LLC. All rights reserved.